Go Back   Starboard Forums > Free Forum > Problem With footstrap box

Thread: Problem With footstrap box Reply to Thread
Your Username: Click here to log in
Image Verification
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Additional Options
Miscellaneous Options

Topic Review (Newest First)
3rd April 2009 08:43 AM
Screamer Roger

What about permanently fixing the screw in the damaged hole? I know my preferred position for the footstrap and never change it. So if I fill the hole with 2-part epoxy resin and let it cure with screw in place, will it hold? (I've tried Permatex, but it didn't harden at all. Must be expiry date or bad storage)

Agree that all this doesn't contribute to brand image.
3rd April 2009 06:33 AM
ducati SUPRISE SUPRISE look what I found

http://www.star-board.com/2009/pages.../designDev.php

don't know how long it's been there

Quote
"32mm FOOTSTRAP SCREWS
New longer footstrap screws for easier strap fitting
Increased pull-out resistance
Stronger screw head "
Unquote

Should have been 35mm (original problem ones was 27mm long)
Is starboard actually admitting they were wrong?
Shouldn't they be giving the screws free of charge to all who have had problems?
Feel sorry for those who took their bad/expensive advice (not me) and tried "Loctite"
28th March 2009 05:47 PM
Unregistered I know I`ve said it before but bonding to the plastic inserts is at best risky.(Does depend on platic used)The figures quoted by Loctite for thread repair are talking about bonding to metal.
A mechanical repair is better.ie oversized screws or some type of "rawl" plug.
Totally agree with last posters comments though ! Why does it happen in first place !
Good luck whatever you do !!
27th March 2009 08:07 PM
ducati
Quote:
Originally Posted by Langdon View Post
Unfortunately you can't get that Loctite thing everywhere.
Seems to be an easy way to solve it, but not if you can't get it

Anyone know if there's an alternative ?
Firstly fill the damaged hole with epoxy and redrill 4mm carefull with depth

I went to a specialised bolt supplier (not hardware shop) who just happen to have stainless steel self tappers with exactly the same thread pitch and slightly bigger in dia.
(very important don't use the finer pitch ones)
You'll have to cut them down to 35mm long
The SB ones are only 27mm long , the insert is 25mm deep, the footstrap and antitwist thingos are 16mm, leave 5mm clearance...........do da maths
Replace all 8 screws

JP actually supply 2x spare oversize screws with their boards (never had any probs with their inserts)

Why an excellent board manufacturer like Starboard lumber us with crap footstraps, wrong screws and crap fins is beyond me
26th March 2009 05:22 PM
Roger Perhaps the Loc-tite kit is not available everywhere.
If you live in a country that has quite a few vehicles, go to either a large
auto/truck parts store or an industrial bearing supply store. They should have
this product or something very similar.
Also, I'm pretty sure you can buy it via the internet and have it shipped to
your doorstep.
26th March 2009 04:24 PM
Langdon Unfortunately you can't get that Loctite thing everywhere.
Seems to be an easy way to solve it, but not if you can't get it

Anyone know if there's an alternative ?
22nd March 2009 10:07 AM
Roger Hi Windculture,
Check this link that describes the methodology and products to repair stripped
Footstrap screw inserts:
http://www.star-board.com/2009/pages...sst_repair.php
Scroll down to the bottom of the page and there's info on how to repair your
problem.
Also, try to find some of the '09 footstrap screws which are 32 mm long vs the
28 mm used on earlier boards.
Over the years, the "stack up" of the K-9 anti twist plates, tooth washers etc, used up too much of the screw length, so the longer screws are now provided with new boards.
22nd March 2009 09:56 AM
nonopr Pedro que box hablas?
22nd March 2009 07:59 AM
windculture
Problem With footstrap box

I have 2 boards starboard 2008, tighten the screw and the box was damaged,this happened on 2 boards.
I have starboard boards of other years and this never happened.
someone had the same problem?
how can I solve this problem without putting a new box?

Thanks

Pedro Lopes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT +7. The time now is 03:18 AM.