Go Back   Starboard Forums > Free Forum > Wrong measurements on Futura 2009

Thread: Wrong measurements on Futura 2009 Reply to Thread
Your Username: Click here to log in
Image Verification
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Additional Options
Miscellaneous Options

Topic Review (Newest First)
27th August 2009 03:40 PM
Unregistered
Quote:
Originally Posted by Unregistered View Post
Hi there, I`ve bought a new futura 101 2009 model. In all the brochures and websites this board is 239,5 x 65. However on the board the specs is 240 x 65,5!? How is that possible? The futura 2009 should be all new models with new designs! Is there anyone with the same problem?? I`ve seen that one guy have had the same problem with the Futura 93 2008.
yes, i have a same problem. They was in brochures 239,50 x 61, and actual board specs was 59, wich is greater for me, but is simullar problem!
2nd July 2009 09:59 PM
Unregistered Hi again

Thank you for your reply and this was my expected answer as one of my peers told me this earlier. However I would like to say that the Futura 101 2009 model is just fantastic, as it flies through chop at a very impressive pace. It is also very easy to control, easy on the plane etc. I`m very pleased with Starboard handling and ride and I`m looking forward to test it out further. Will the new Futura 2010 available in carbon edition?
2nd July 2009 06:26 PM
Tiesda You Hi Guest,

The master plug measures 239.6 x 65.4cm. We had different teams working on the board graphics and the website/brochure specs so one team rounded up and the other rounded down. We've changed the system around now so that the specs are more consistent.

Cheers,

Tiesda
2nd July 2009 12:04 AM
Unregistered
Wrong measurements on Futura 2009

Hi there, I`ve bought a new futura 101 2009 model. In all the brochures and websites this board is 239,5 x 65. However on the board the specs is 240 x 65,5!? How is that possible? The futura 2009 should be all new models with new designs! Is there anyone with the same problem?? I`ve seen that one guy have had the same problem with the Futura 93 2008.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT +7. The time now is 10:45 PM.