Go Back   Starboard Forums > Free Forum > Footstrap-plugs. Bad quality on FUTURA ?

Thread: Footstrap-plugs. Bad quality on FUTURA ? Reply to Thread
Your Username: Click here to log in
Image Verification
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Additional Options
Miscellaneous Options

Topic Review (Newest First)
26th September 2009 04:21 AM
Benoit29 Go to
Product/product assistance/repair guide
and you will find starboard way to fix it.
25th September 2009 03:49 PM
Unregistered Had the same problem and fixed it with epoxy glue. I used the soft rubbery type epoxy not the stone-hard type, this type will crack when you try to refit the screw.

Drill out the hole to 6mm, fill it with glue and then drill a 3-3,5mm hole to refit the screw.

This worked for me (twice!!!!! with two different footstraps on my Futura 133)

/Jan
25th September 2009 01:17 AM
nonopr That happens when you dont screw the screw the right way the first time or the board did not bring the new longer screws that starbosrd has outfitted their boards with lately.
The original screw lenght was 28mm but now they use a 32mm screw. Maybe you can use the longer screw now.
25th September 2009 12:57 AM
Unregistered
Footstrap-plugs. Bad quality on FUTURA ?

Today when I was cruising nice and easy on my nearly new (this was the sixth time surfing) FUTURA 122 Wood, the outboard screw on the lefthand footstrap came loose.

And that was not because the screw was not tightened proberly, no the plastic tread in the insert was torn out by the screw !

How can this happen on what I belived was a quality board ?

And how can I repair the plug ? if that is possible at all.

Anybody eperienced the same ?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT +7. The time now is 10:41 AM.