Go Back   Starboard Forums > Free Forum > 2012 Phantom mast track problems

Thread: 2012 Phantom mast track problems Reply to Thread
Your Username: Click here to log in
Image Verification
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Additional Options
Miscellaneous Options

Topic Review (Newest First)
12th April 2012 07:46 PM
ZedZdeD I had a problem of pedal staying down on my 320 2011. Cause and solution were as follows :

Cause (in my case) :

when you disassemble the mast track, you can see that the force which normally allows the pedal to go upwards comes from a bent metal piece which is inserted in the rail mobile part (the part with holes in which the mast foot locks)

in my case pedal did not go up because the angle in which this metal piece was bent was wrong, too high, then the force needed to bring the pedal down was too high, and when bringing the pedal down the metal piece went on the side instead of down, and the pedal would not come up again

Solution (in my case) :

I broke the edge of the metal piece which was bent with a wrong angle, and bent it again with a lower angle, and things came back in order

If you do this be careful not to reduce too much the angle, otherwise the force to bring the pedal up will be weak

Rgds
10th April 2012 03:02 AM
Remi Hi Nock

Can't check right, I have only my phone in Maui.

If you send this to your Distributor, Waranty procedure will follow.

Sorry for the inconvenience

All the best
10th April 2012 02:39 AM
NickB Bonjour Remi,
The caoutchouc part behind the paddle is still there. I have sent you a picture showing the problem a little better, maybe it will shed some light? I have sent the same picture to my dealer/distributor.
Kind regards,
Nick
9th April 2012 08:38 PM
Remi Hi Nick

Do you have the soft caoutchouc just behind the paddle, if not the paddle will lock down automatically.
If you have it at this time the mast track is probably broken.
For the mast base who get out, this happen when is not properly lock, please see this video : http://vimeo.com/30129709

Let me know after check this 2 points, thanks

All the best
9th April 2012 05:37 AM
Roger Nick,
You make it sound so easy!
Yes, you need to take all the screws out of the bottom of the mast track, but the
track does not always want to pop right out.
You've got the idea, and if the dealer/distributor give you the go ahead that's how I
would proceed, but as I said, do not expect to take out the screws and simply grab the
track and pop it out of the board. It could be that easy...but I've never had one come out
that easily.
Roger
8th April 2012 04:07 PM
NickB Thank you for your guidance Roger.

I have contacted my dealer and will let you know how it turns out. I won't disassemble it before I get the OK from the dealer, but if so, it seems that removing the track assembly is easy enough. Could you confirm one just has to unscrew the 6 bottom screws and pull the track assembly out of the board?

Thanks again,

Nick.
8th April 2012 12:49 PM
Roger Nick,
Not sure, without actually seeing it, but I do not think the stainless bit should be just lying there.
I would contact the dealer where you bought the board and see if they can get you another mast
track assembly under warranty.
If the car slides back and forth OK, you should be able to remove all the screws that hold it down in
your board.
Perhaps if you get it out where you can manipulate the pedal more easily you could get the spring
back in place.
But contract your dealer and Trident Sports first and see what they suggest.
Roger
8th April 2012 02:43 AM
Unregistered Hi Roger, thanks for your quick answer.

My board did not come with a pin/uni originally, and of course my existing ones didn't fit, but my dealer contacted the North America Starboard distributor who graciously shipped one to me (Phantom mast base, fits very good except for that one time when it popped out during a jibe).

Regarding the pedal, I tried to pull it forward toward the front of the mast track, but it didn't re-engage. The pedal is just loose, like the spring that is supposed to raise it is broken or something. I'm not sure if this link will work but here is a picture: (put http in front) sphotos.xx.fbcdn.net/hphotos-prn1/555556_3682581307565_1366074642_3564802_80981852_n .jpg
I see a little piece of stainless steel wire laying flat under the pedal and am wondering if that may be the spring mechanism that got separated from the pedal somehow. Is it normal to see this stainless steel bit (looks like part of a thick paperclip) loose under the pedal?

Thanks again,

Nick
8th April 2012 01:29 AM
Roger Hi Nick,
First, did you use the pin/uni that was provided with the board, or something else?
Secondly, it sounds like your release pedal may be stuck half way between the "press
pedal to relaese position" and the pedal back and locked down almost flush with the deck position. When the pedal is pushed back to the locked position, the mast car should be able to lock in
any of the slots in the rail.
Can you check to see if the pedal can be pulled forward toward the front of the mast track, and if it re engages in that position?
Hope this helps,
Roger
P.S. the pin that was supposed to come with the board is about the only one that will fit securely
under the locking U clip.
When we first had this issue (on the first Phantom ever imported into the US) we had to borrow a pin/uni from the Exocet folks as their mast tracks and the ones in the Phantom all come out of Cobra.
We tried North pins/ Mistral pins/F2 pins from oler boards, and none of them fit securely.
7th April 2012 11:55 PM
NickB
2012 Phantom mast track problems

Hi,

Yesterday I took out my 2012 Phantom 320 for the first time, and it was very nice (8-12knots, railing and a bit of planing). The mast track seemed to be working fine, unlocking when I pressed the pedal and locking back up when in the new position. But after 1.5 hour, as I was 3km inside San Francisco bay, my rig separated from my board during a very gentle pivot jibe. Thankfully I was able to hold on to both the rig and board! The Phantom mast base had just popped out of the mast cart, even though the U-pin that locks it in place was still in the "locked" position. Strange. But after struggling a few minutes I was able to set the base back in position and make it back to shore safe. Pfeew!

But today, as I was preparing for my second session on that board, I checked the mast base/cart before leaving. In doing so, I pressed the pedal (gently, with my hand) to reposition the cart to a back position, and heard a loud sound. It must have been some kind of spring in the pedal mechanic that broke, because the pedal won't come back up by itself anymore, and the track stays down in the "unlocked" position even when the cart is set correctly in one position. I can lift the locking mechanism manually to lock it, but it falls back down in the unlocked position by itself (gravity), making the board unusable.

Has anyone seen this happen? per pictures, I think the track is the same for all Phantoms (320, 377, 295), but I have not found any other posts of users having this problem.

I would have posted in the "ask the team" forum but forum registration has been disabled. Can anyone from Starboard let me know if there is a way I could fix it, or does it sound like a defect and should I already have my dealer contact the Starboard distributor for some kind of replacement?

Thank you,

Nick
(I can email pictures if needed)

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT +7. The time now is 10:04 PM.