Starboard Forums

Starboard Forums (http://www.star-board-windsurfing.com/forum/index.php)
-   Ask Our Team (http://www.star-board-windsurfing.com/forum/forumdisplay.php?f=10)
-   -   screws don't fit (http://www.star-board-windsurfing.com/forum/showthread.php?t=11550)

madsurfer 17th March 2011 12:22 AM

screws don't fit
 
Hi I'm was inserting my footstraps into my brand new Isonic 121 2010 (on BOOT Dusseldorf 2011) but I have a hard time getting the screws in. It's seems that the thread and the screw are not connecting/gripping (don't know the exact word for it in English). I don't want to mess up the plugs. It seems that the screws are to big or that the thread is missing. I can get a screw in only 1 of the holes...

What would you advice me to do?

SeanAUS120 17th March 2011 04:44 AM

Madsurfer,

The screws are quite tight in the 2011 iSonics; I didn't have the '10 versions but can only assume the same. Best thing to do is grab a bar of soap and wipe a little on the screws before you put them in as a lubricant. Use a good screwdriver and go slowly to make sure you don't cross thread... when they are this tight they grip really well so you shouldn't pull any out like thinner bolts used to do occasionally.

S.

Roger 17th March 2011 05:55 AM

Hi Madsurfer,
Sean has it right!
The holes cast in the footstrap inserts are very tight on the new 7mm dia. PT (Plastics Technology) screws.
Here are some tips:
1/ Put bar soap (bath tub bar) on the screws before you try to screw them in. The soap serves as a lubricant!
2/ Take one of the screws and install it (without the footstap) in all of the holes/FS plugs you intend to use!
This will "pre-thread" the inserts to the correct diameter and cut some threads (like a tap would) in the insert so when you install the screws through the footstrap/washers/K9-locks there will already be some good threads near the top of the insert so the new screws (lubed with soap) will start easily.
3/ Buy a high quaility heat treated tip #3 Phillips Screwdriver. Anything but the correct tool will simply damage the Phillips drive recesss/angles in the top of your new screws!
4/ Take 2 pair of vice grips (or a common "C" clamp or 2) and compress the K9-lock pins (the sharp points
side) up into the webbing of the footstrap. Better still, take the whole "stack up" (footstrap/K9-lock/tooth washers/flat washers) and compress them all together so the screw (now 32 mm long vs 28 mm for the older 6mm x 28 mm PT FS screws) sticks out far enough so it can really get started in your "pre-threaded" holes.
Another way to accomplish this is to get several 6mm x1.0 bolts/cap screws about 40 mm long and some 6mm flat washers and 6mm x 1.0 nuts. Stack up all the FS components (washer/toothwasher/footstrap webbing/K9-lok
and put a washer on the outside of the K9Lok. Tighten the nut to compress everything together and sink the K9lok points into the webbing.
5/ Do NOT use any sort of power driver as this will overheat the screw and damage the insert!!!!!
6/ When you have the footstrap webbing/K9-lok/washers and the new FS screw (lubed with soap) all assembled, use the correct #3 Phillips tip screwdriver and tighten the screws.
Take you new board out and sail it for a short session!
Retighten all the footstrap screws.
I know, all this is a bit of a PITA from using the old 6mm PT screws, but a little time and effort spent getting this right will mean you will probably never have any issues down the road with your footstraps on the new board.
Cut corners here, do it too fast with a power tool, fail to pre thread the inserts and lube the screws, and you almost for sure will be having the FS inserts replaced at some point because one or more of the screws stripped out.
Hope this helps,
Roger

madsurfer 17th March 2011 03:03 PM

Thanks guys, I will try that tonight and let you know.

madsurfer 21st March 2011 02:54 AM

I still don't get the screws in. The soap helped a little bit for some of the holes but not for all. I will go to a shop and see what they have to say.

Roger 21st March 2011 11:10 AM

Hi Madsurfer,
Did you "pre thread" all your holes?
To do this, take a screw and simply screw it down into each hole you intend to use.
This will put threads in the hole that the screw can follow when you stack up the footstrap/
K9-lok and washer (s).
Also, it's very important to "compress" the foostrap/K9lock and washers so the screw threads are
well clear of the K9lok so they can engage the threads you have "pre threaded" in the hole.
Hope this helps,
Roger

madsurfer 23rd March 2011 02:44 AM

1 Attachment(s)
The problem was getting them pre-threaded but i succeeded now. I think some of the glue meant for the footpad was stuck in the holes. I used the tip of the screwdriver to get all obstacles away. Then I tried each screw on each hole until I got it in and I repeated that process for each hole. As you can see in the picture, some holes were not completely round. Now I will install the straps.

Roger 23rd March 2011 07:01 AM

Hi again Madsurfer,
Glad to hear that you got all the screws started.
I see another potential issue in your photo.
The difference in thickness of the "fish scale' pad where it changes from the lower
black to the higher white could be a real problem to get the K9-Lok to sit flat when
you tighten the FS screw down on top of the footstrap/K9-Lok and washer on the
plate on the top of the footstrap.
I would suggest taking a small exacto knife and cutting clearance for the K9-Lok
plate diameter in the white fish scale where it significantly higher that the black.
(This would only be the forward outboard hole on each side of your board).
If there are other "differences in elevation" where the K9-Lok plate diameter
is going to land, do what you can to even the fish scale out so the lock plate
comes down flat (not at some crazy angle that will put alot of shear load on the
7 mm PT FS screw.
Enjoy your new board, sorry that you had these difficulties!
Roger

Brett Morris 24th March 2011 07:05 AM

I just about blew a blood vessel putting the straps on my new board.
I know the smaller screws were snapping sometimes, which was definitely undesirable, but surely some
fine tuning at the factory i.e. a slightly larger hole is an easy fix?
It wold be a shame if customers receive a cool new board, but can't put the foot straps on themselves.

PS, i have heard this problem has been addressed already....Cheers

madsurfer 26th March 2011 11:29 PM

I got all the footstraps on the board. Now it's time to get on the water :-).


All times are GMT +7. The time now is 06:45 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.