Starboard Forums

Starboard Forums (http://www.star-board-windsurfing.com/forum/index.php)
-   Free Forum (http://www.star-board-windsurfing.com/forum/forumdisplay.php?f=9)
-   -   2005 Sonic 100 (http://www.star-board-windsurfing.com/forum/showthread.php?t=3218)

aread 8th January 2008 05:38 PM

2005 Sonic 100
 
Hi

I am having trouble pointing (beating) on my Sonic 100. I am running the standard 34cm fin with a Pryde RS5 6.2mē and am well powered. When I start to accelarate near top speed I tend to start bearing down wind too much. What could be the problem?

Thanks
Adrian

erik 12th January 2008 04:35 AM

Hi,
I had the same problem when i owned a sonic 100.

i think is the outline of the board.
You can try to push hard on the leeward rail.

The isonics don't have that problem anymore.

greetings from holland

mark h 12th January 2008 07:03 AM

Untill a couple of months ago, I had a Sonic 100 for a couple of years. It was a brilliant board (S100/7.6m/Evo 35cm is my all time favourit comb, 15 to 30 knots mile eater in any sea state). I'v just got rid of a load of sonics (125/100/90) & F159 for three new 08 iS's (76/111/144) to keep things simple. The Drake 34cm supplied with the S100 was not to good for me so I got an 05 Select Evo 35cm (for 7.6m Warp) and a 31cm Evo (for 6.8m Warp). Both these fins improved upwind loads. Also improved the ride through heavy chop. Maybe a fin change will help you out.

Cheers


All times are GMT +7. The time now is 12:52 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.