Starboard Forums

Starboard Forums (http://www.star-board-windsurfing.com/forum/index.php)
-   Free Forum (http://www.star-board-windsurfing.com/forum/forumdisplay.php?f=9)
-   -   Footstrap-plugs. Bad quality on FUTURA ? (http://www.star-board-windsurfing.com/forum/showthread.php?t=7341)

Unregistered 25th September 2009 12:57 AM

Footstrap-plugs. Bad quality on FUTURA ?
 
Today when I was cruising nice and easy on my nearly new (this was the sixth time surfing) FUTURA 122 Wood, the outboard screw on the lefthand footstrap came loose.

And that was not because the screw was not tightened proberly, no the plastic tread in the insert was torn out by the screw !

How can this happen on what I belived was a quality board ?

And how can I repair the plug ? if that is possible at all.

Anybody eperienced the same ?

nonopr 25th September 2009 01:17 AM

That happens when you dont screw the screw the right way the first time or the board did not bring the new longer screws that starbosrd has outfitted their boards with lately.
The original screw lenght was 28mm but now they use a 32mm screw. Maybe you can use the longer screw now.

Unregistered 25th September 2009 03:49 PM

Had the same problem and fixed it with epoxy glue. I used the soft rubbery type epoxy not the stone-hard type, this type will crack when you try to refit the screw.

Drill out the hole to 6mm, fill it with glue and then drill a 3-3,5mm hole to refit the screw.

This worked for me (twice!!!!! with two different footstraps on my Futura 133)

/Jan

Benoit29 26th September 2009 04:21 AM

Go to
Product/product assistance/repair guide
and you will find starboard way to fix it.


All times are GMT +7. The time now is 12:36 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.