View Single Post
Old 7th May 2008, 07:59 AM   #6
Roger
Dream Team - School Guru
 
Join Date: Aug 2006
Posts: 2,110
Default

Hi Ola, and Kerim,
Yes, I know about this problem, and have had it myself.
They will correct it next year by providing longer screws (32 mm long vs 28 mm long now).
And, you are correct, it's a mounting problem.
If you get a 6 mm bolt and nut and a couple of fairly thick flat washers, you can "pre-compress" the K9 lock plate (the anti-twist plate with the tag on one side and the big "spikes" on the other side), the toothed washer, and the footstrap mounting area so that when you go to install it in the board, the screw is long enough.
I've seen a few where the screw really didn't "engage" and start cutting threads,but rather kinda "stripped" the top of the hole in the insert due to the lead in taper on the screw.
The only fix I know is to get the 6mm bolt and nut, and really compress the K9 lock plate (in the correct orientation to fit your board), and the rest of the materials that have to be under the footstrap screw so the screw can engage normally.
I suspect that you've only stripped the top part of the insert, so you should be OK if you compress everything and then use a new FS screw.
If not, then the process recommended on the repair link:
http://www.star-board.com/2008/pages...sst_repair.php
is about the only solution I know of.
But, as Ola suggests, take the board back to your dealer and see what they will do
under warranty.
Hope this helps,
Roger is offline   Reply With Quote