Go Back   Starboard Forums > Windsurfing School

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 27th October 2009, 01:17 AM   #1
Lasher
New Member
 
Join Date: Oct 2009
Posts: 7
Default What's wrong with IS 133 or it's just me?

Just bought a 2009 IS 133 for low/mid wind days ie 12-20 knots.Today it was blowing 24-28 kts.I'm 80 kgs and actually I prefer 101-110 Lts in such winds but I was eager to test my new toy.The board came with 52 cm drake fin default.I rigged a 6.5 severne.Straps were outer and back positioned.I consider myself an experienced windsurfer.I have rode countless brand boards from 86 to 160 and sails up to 10.5.
Anyway,I felt something is very wrong from the moment I started.The board wants to turn and go upwind whatever stance I assumed.Played with MFT,harness lines,changed the sail to 7.5,overpowered and things got even worse.Changed the sail to 5.8.Played with downhauls and outhauls.Whatever I did,didn't work.It goes like a sky rocket upwind but I could not persuade the board go downwind!!!

Please don't start briefing me with the going downwind technics.I never had a problem going up or down or left or right or whatever in the last 10 years with any other board.
The starboard dealer is an experienced racer and he was on the beach while I struggled.When I told him that I was sure the source of the problem is the size of the fin,that is too big,he said "No,this is the I-Sonic man,a different breed board, and this is the default fin and this is the best set up.The problem is with you".
He may be right,because this is the first time I rode an IS.Now I feel rookie after all those years of sailing.Is it possible that IS boards are so different?
Thanks in advance for your help.
Lasher is offline   Reply With Quote
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrong measurements on Futura 2009 Unregistered Free Forum 3 27th August 2009 03:40 PM
bug report - wrong dimensions in formula page tsvetelin Free Forum 2 26th August 2007 05:45 AM


All times are GMT +7. The time now is 02:39 AM.