Go Back   Starboard Forums > Free Forum

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 20th July 2011, 02:13 PM   #1
Farlo
Member
 
Join Date: Aug 2006
Posts: 528
Default Wishbone broken

Hi everybody,
The other day my wishbone broke suddenly when I was nicely powered up with 7.8 in some 15 knots. Water was rather flat so no particular shock that I can remember. It is a Nautix aluminium boom that I've been using for about seven years, mostly freeracing with sails bigger than 6. The inner tube (protruding from the head) is cut without signs of previous damage or rust. Can it be just stress and strain? I wonder because I'm relatively light (67 Kg) so I can't load it tremendously. Did any of you experience a similar thing?
Farlo is offline   Reply With Quote
 

Bookmarks

Tags
None

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
broken u.s. fin - need advice dominic72 Ask Our Team 6 13th August 2009 06:53 PM
broken footstrap?! jonthesailorman Ask Our Team 2 8th April 2008 01:54 AM
wishbone Guest Free Forum 1 21st June 2007 03:50 AM
Broken code red batten martwald Free Forum 5 10th January 2007 02:24 PM
wishbone neilpryde x9 speedy French Forum 11 27th November 2006 02:15 AM


All times are GMT +7. The time now is 11:54 PM.