Go Back   Starboard Forums > Free Forum

Reply
 
Thread Tools Display Modes
Old 14th November 2010, 03:06 AM   #1
Unregistered
Guest
 
Posts: n/a
Default Starboard Rio problem.

Hi all,
This morning I got out my Rio that I bought new only a few months ago, I noticed underneath there were lots of small ( size of a pinhead ) bumps all over. >.<

What could have caused this?
I always unscrew the air valve and give the board a wipe down after use.
Its is also stored in a pretty dry shed, any Ideas?
  Reply With Quote
Old 14th November 2010, 11:31 AM   #2
Roger
Dream Team - School Guru
 
Join Date: Aug 2006
Posts: 2,112
Default

I would suggest that you take some detailed photographs of the "pinhead bumps" and speak with the dealer where you bought your Rio.
There could be a warranty on this sort of damage, and contacting your dealer with good hi resolution photos is the best way to start the warranty process.
Roger
Roger is offline   Reply With Quote
Old 16th November 2010, 06:50 PM   #3
Unregistered
Guest
 
Posts: n/a
Default

Ok I brought the board into the house to let it completely dry out over the last couple of days, the amount of bubbles has now reduced to about 10% the original amount.
There is no damage to the structure of the board whatsoever.
All these tiny bubbles were filled with water just under the paintwork, I will see how they go over the next couple of days before I contact the supplier.
I am led to believe that this is caused by leaving it in a damp board bag.
  Reply With Quote
Old 20th November 2010, 12:41 AM   #4
Unregistered
Guest
 
Posts: n/a
Default

you are basically screwed, starboard wont do crap about this
thats why I will never buy another Starboard board.

none of my other board have had this problem and i've been storing them wet in bags for years
  Reply With Quote
Old 20th November 2010, 12:48 AM   #5
Unregistered
Guest
 
Posts: n/a
Default screw starboard, buy JP, F2 or Fanatic

The same thing happened too me, Starboard refused to do anything about it so I listed the board for sale on Ebay and showed close up photos of the blistered bottom. I believe over 300 people clicked on the ad and saw what crap they are selling
that was in 07, looks like they are still making crappy boards today.

until people start doing something about it and quit buying their boards they will continue to screw the little guy and I dont know about you but $1400 is a lot to pay for a board thats going to fall apart in less than a year

Screw you and your boards starboard!
  Reply With Quote
Old 20th November 2010, 02:25 AM   #6
Ken
Member
 
Join Date: Aug 2006
Location: Dallas, Texas USA
Posts: 799
Default

Unregistered,

All manufacturers turn out bad boards from time to time. I can't speak to the percentage of bad boards from Starboard vs other brands, but my own experience with Starboard (4 boards) has been excellent.

The key issue is how does the company respond to warranty issues. I wonder if both of you followed the stated warranty process (as Roger suggests) and then were denied repairs or a replacement within the warranty time period?

If indeed you followed the required process and were denied the claim, then you have a legitimate gripe. If you are bummed out because in your opinion, Starboard treated you unfairly, and if you want sympathy from the forum readers, you should detail your experience, register and provide a name, then we may listen and learn from your experience. Otherwise, go waste your time someplace else.

The board with the bubbles sounds really strange. Storing a board in a wet bag should not create bubbles in the paint, or anything else I can think of. Sounds like bad paint on the board. Hopefully, Starboard will work with you for a resolution.

And for those that don't support your local windsurfing shop (if you have one), here is an excellent reason to do so. Got your board mail order? How is the warranty claim process working for you?

I am not a shop owner or employee, but I believe in supporting your local dealers.
__________________
Toys:
Formula 160; iSonic 111; HiFly Move 105; Tiga 263; '85 Mistral Superlight.
Maui Sails TR 11.0; 9.2; 8.4; 7.6; 6.6; Maui Sails Switch 6.0; 5.2; Maui Sails Global 4.5; 4.0.
Ken is offline   Reply With Quote
Reply

Bookmarks

Tags
None

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starboard Phantom Race 320 2009and 2010 - problem of water absorption ZedZdeD Ask Our Team 12 29th November 2010 08:57 AM
Some problem cohibarobustos Ask Our Team 0 25th January 2010 03:13 PM
Web Site Problem? Ken Ask Our Team 2 30th September 2009 11:44 PM
q f ian trim problem erik Ask Our Team 0 13th April 2008 10:53 PM
Isonic 122 problem AJ Ask Our Team 4 18th September 2007 06:32 PM


All times are GMT +7. The time now is 11:09 PM.