Go Back   Starboard Forums > Ask Our Team

Reply
 
Thread Tools Display Modes
Old 4th May 2010, 04:53 PM   #1
SlimShady
New Member
 
Join Date: Apr 2007
Posts: 3
Default Formula 160 - Adhesive Advice Needed

Hi,

I've recently bought a 2nd hand Starboard Formula 160. When I got the board one of the plastic protective washers that are normally stuck on the top surface of the rear of the board where the fin bolts go through was missing. I've got a replacement plastic washer from my Starboard dealer but I'm having difficulty sticking it to the board.

So far I've tried to stick it back on with the following:

- Evo Stik Timebond Contact Adhesive - the adhesive stuck to the board but not to the plastic washer.
- Superglue - It appeared to work but after the first session back on the water when I removed the fin the plastic washer dropped off.

Can anyone recommend me an adhesive that I can use that won't damage the board ?

Thanks, Mark
Attached Images
File Type: jpg SB_0.jpg (83.5 KB, 3 views)
File Type: jpg SB_1.jpg (45.5 KB, 6 views)
SlimShady is offline   Reply With Quote
Reply

Bookmarks

Tags
plastic washer adhesive

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Advice needed for Board Set iSonic 94 111 131 or 144 xbraun Ask Our Team 4 16th February 2010 06:37 AM
Advice needed ! Unregistered Free Forum 18 14th June 2008 02:53 PM
Advice needed RandyP Windsurfing School 1 12th September 2007 06:29 PM
Footstrap and fin advice needed for Carve 144 different Free Forum 2 24th January 2007 07:59 PM
K9 antitwist in Aero 117 - advice needed windracer Ask Our Team 2 21st August 2006 03:59 PM


All times are GMT +7. The time now is 03:45 PM.