Go Back   Starboard Forums > Free Forum

Reply
 
Thread Tools Display Modes
Old 22nd September 2011, 01:08 AM   #1
Unregistered
Guest
 
Posts: n/a
Default Lost Nuts!

I bought a used Starboard GO 200. I belive it is about a 6-7yr old model. I lost the slider nut that inserts into the board to attach the mast as it slides back and forth in the groove. How can I replace this nut? Thank you!

Nate
  Reply With Quote
Old 22nd September 2011, 06:28 AM   #2
Roger
Dream Team - School Guru
 
Join Date: Aug 2006
Posts: 2,109
Default

Hello Nate:
The GO 200 does use a brass T-Nut due to the added thickness of the EVA deck.
Any Starboard dealer should have some in stock to sell you.
If you don't have a local dealer, try the Starboard Distributor for your country or area.
If you don't find a Brass T-Nut at the above sources, send an email to Starboard HQ
in Thailand and they can most likely sell/send you a new nut.
Probably smart to get 2 of them as then you will have a spare.
Let me know if you are in the USA, I may be able to find a way to send you one.
Roger
Roger is offline   Reply With Quote
Reply

Bookmarks

Tags
None

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i lost my Vent screw fhguu Free Forum 3 16th September 2011 12:36 AM
Lost mastbase plate joe_windsurfer Free Forum 7 7th April 2011 06:06 AM
The lost password procedure doesn't work Unregistered Free Forum 0 14th April 2008 06:15 AM


All times are GMT +7. The time now is 08:56 AM.