Old 15th January 2007, 07:27 AM   #1
Guest
Member
 
Join Date: Dec 2006
Posts: 1,321
Default broken footstrap screws

Anyone else broken footstrap screws on an 07 Evo?

I've broken 2 off now - one in each hole. So now I can't attach a footstrap. Gotta try to get the broken screws out... Fun.
Guest is offline   Reply With Quote
Old 16th January 2007, 12:02 AM   #2
Jean-Marc
TEAM
 
Join Date: Aug 2006
Posts: 1,292
Default RE: broken footstrap screws

Guest,

Have a look here as a starter of how to remove broken or stripped screws from the footstrap's insert :

http://2006.star-board.com/forum/askteam/read.asp?ID=3216

Cheers !

JM
Jean-Marc is offline   Reply With Quote
Old 16th January 2007, 02:05 AM   #3
-Lampi-
Member
 
Join Date: Nov 2006
Posts: 84
Send a message via MSN to -Lampi-
Default RE: broken footstrap screws

When you get the screws out, then just go buy new ones. But i don't have any idea how to do that... Seems impossible to me... So when you put them out, please let us (or me) know how you did it...
__________________
-Lampi-
-Lampi- is offline   Reply With Quote
Old 17th January 2007, 11:37 AM   #4
Roger
Dream Team - School Guru
 
Join Date: Aug 2006
Posts: 2,102
Default RE: broken footstrap screws

Hi Guest,
How did the foot strap screws break off?
Are they broken off flush with the deck of the board, or is the entire
broken screw down below the surface of the plastic insert?
What tool did you (or the shop where you bought the board) use to install the footstrap screws?
The Tiki Tool Screwdriver....?
A very high quality #3 Phillips Screwdriver.....?
A #3 Phillips bit in some sort of power screwdriver....?
Did you apply soap to the threads of the screw before installing them?
Did you use ALL the washers and the K9 anti-twist when the footstraps were installed?
Trying to determine if you simply broke the screws off (with torque), or perhaps didn't get the K9 lock plates under the footstrap and the oval toothed washer on top of the footstrap webbing.
If you didn't install the K9's or the oval washers, you may have driven the screws too deep and punched out the bottom of the inserts.
If so, best to take your board to a professional and have a couple of new inserts installed. This would eliminate the need to "dig out" the broken screws.
If there is any of the screw still sticking up beyond the top of the insert, a pair of vice grip type pliers is the best tool I know of to remove them.
Get as tight a grip as you can on the exposed portion of the of the broken screw and carefully unscrew the broken screw from the insert.
Since you have a SS screw stuck in a piece of plastic, I doubt you will have any success trying to "drill out" the broken screw, and with the PT threadform, you probably could not get all of the broken screw out.
Are you sure the screws that you used were the stock screws that came with your EVO.
There are alot of #6 x 27 mm screws used in footstraps, but there are also very similar screws that are 25 mm long that are used for the side fins on Go boards and the leash attachment on Starts and Rios.
Hope this helps,
Roger is offline   Reply With Quote
Reply

Bookmarks

Tags
None

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +7. The time now is 03:31 PM.